Commit 3d78d953 authored by VIGNET Pierre's avatar VIGNET Pierre

More precise versions for dependencies: avoid the installation of matplotlib2 with gtk3

parent 0caee3b4
......@@ -92,7 +92,7 @@ setup(
'console_scripts': ['cadbiom_cmd = cadbiom_cmd.cadbiom_cmd:main'],
},
install_requires=deps + ["matplotlib", "cadbiom"],
install_requires=deps + ["matplotlib<2", "cadbiom"],
# Tests
tests_require=['pytest'],
......
......@@ -137,7 +137,7 @@ setup(
ext_modules=modules,
description="Cadbiom library",
long_description=open('README.md').read(),
install_requires=["networkx", "lxml", "pygraphviz", "pycryptosat"],
install_requires=["networkx<2", "lxml", "pygraphviz", "pycryptosat"],
# Tests
tests_require=['pytest'],
......
Markdown is supported
0% or
You are about to add 0 people to the discussion. Proceed with caution.
Finish editing this message first!
Please register or to comment